股票查詢: 行情分析 題材分析 DDX在線 業績報告 個股吧 業績預告 業績披露 股東人數 機構持股 高管 公告 個股研報 十大股東 資金流向 個股分紅
您的位置:愛買股網 > 買股公式 > 公式正文
股票公式搜索:

通達信強勢主升龍頭選股指標公式[買股公式]

2023/4/5 22:09:39

VAR1:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
VAR2:=IF(DATETODAY(DATE)<999999999,1,DRAWNULL);
VAR4:=EMA(CLOSE,10);
VAR7:=EMA(CLOSE,40);
VAR8:=EMA(CLOSE,60);
VAR9:=IF(DATE<999999999,1,DRAWNULL);
VAR10:=MAX(VAR7,VAR8);
VAR11:=CLOSE>VAR10 AND VAR1 AND (CLOSE>REF(HHV(HIGH,3),1)*VAR2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07);
VAR12:=vol;
VAR13:=MA(VAR12,5);
VAR14:=VAR13+VAR13>VAR12;
VAR15:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)*VAR2 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10)*VAR9;
VAR16:=(CLOSE>REF(HHV(HIGH,3),1)*VAR2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.07)*VAR2 AND VAR15 AND VAR14;
VAR17:=DYNAINFO(4)>0 AND HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)*VAR2<LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85 AND CLOSE>OPEN AND CLOSE>=HHV(HIGH,10);
VAR18:=(CLOSE-REF(CLOSE,1)*VAR2)/REF(CLOSE,1)*100>7;
VAR19:=VAR17 AND VAR18;
VAR20:=DATETODAY(DATE);
VAR21:=VAR20>9344 AND VAR20<999999999;
VAR22:=(VAR11 AND VAR19)*VAR21;
VAR23:=EMA(CLOSE,5);
VAR25:=EMA(CLOSE,14);
VAR26:=EMA(CLOSE,18);
VAR27:=EMA(CLOSE,40);
VAR28:=EMA(CLOSE,60);
VAR29:=MAX(MAX(MAX(MAX(MAX(VAR23,VAR4),VAR25),VAR26),VAR27),VAR28)*VAR9;
VAR30:=MIN(MIN(MIN(MIN(MIN(VAR23,VAR4),VAR25),VAR26),VAR27),VAR28)*VAR9;
VAR31:=CLOSE>VAR29 AND LOW<VAR30 AND (CLOSE>REF(HHV(HIGH,3),1) AND (CLOSE-REF(CLOSE,1)*VAR2)/REF(CLOSE,1)>0.09);
VAR32:=FILTER(VAR31>0,0)=1;
VAR33:=DATETODAY(DATE);
VAR34:=VAR33>9350 AND VAR33<999999999;
VAR35:=VAR32*VAR34;
VAR36:=MA(REF(HHV(CLOSE,26),1),2);
VAR37:=MA(CLOSE,26);
VAR38:=POW(CLOSE-VAR37,2);
VAR39:=MA(VAR38,13);
VAR40:=SQRT(VAR39);
VAR41:=VAR37+2*VAR40;
VAR43:=crOSS(CLOSE,VAR36) AND HIGH>REF(VAR41,1) OR (CLOSE>VAR36 AND CROSS(CLOSE,REF(VAR41,1))) AND CLOSE/OPEN>0.998;
VAR44:=macd.MacD;
VAR45:=kd.K;
VAR46:=KD.D;
VAR47:=rsi.RSI1;
VAR48:=RSI.RSI3;
VAR49:=CLOSE-REF(CLOSE,1);
VAR50:=IF(VAR49>=0,VAR49,0)*VAR9;
VAR51:=IF(VAR49<0,-VAR49,0)*VAR9;
VAR52:=MEMA(VAR50,10);
VAR53:=MEMA(VAR51,10);
VAR54:=MEMA(VAR50,6);
VAR55:=MEMA(VAR51,6);
VAR56:=MA(100*VAR52/(VAR52+VAR53),10)*VAR9;
VAR57:=MA(100*VAR54/(VAR54+VAR55),6)*VAR9;
VAR58:=MA(CLOSE,5)/MA(CLOSE,10)>0.999 AND MA(CLOSE,10)/MA(CLOSE,20)>0.9847 AND MA(CLOSE,20)>MA(CLOSE,60) AND REF(COUNT(MA(CLOSE,10)/MA(CLOSE,20)<1.017 OR MA(CLOSE,5)/MA(CLOSE,10)<1.017,8)>=1,1) AND MA(CLOSE,20)/MA(CLOSE,60)<1.121;
VAR59:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
VAR60:=COUNT(VAR59<35,100)>=95;
VAR61:=VAR43 AND VAR58>0 AND NOT(DYNAINFO(4)=0) AND VAR60 AND REF(COUNT(MA(CLOSE,20)>MA(CLOSE,30),4)=4 AND COUNT(CLOSE>MA(CLOSE,5),3)>=2,1) AND VOL>REF(VOL,1) AND (REF(COUNT(CLOSE>OPEN,10)>=6 OR COUNT(CLOSE>OPEN,5)>=4,1) OR CLOSE=HIGH) AND (CROSS(VAR57,VAR56) OR CROSS(VAR44,0) OR REF(COUNT(CROSS(VAR44,0),3)=1 AND VAR44<0.15 AND CLOSE/OPEN>0.989 AND CLOSE/REF(CLOSE,1)<1.03,1) OR CROSS(VAR45,VAR46) OR CROSS(VAR47,VAR48)) AND REF(CLOSE/OPEN>0.988 AND (CLOSE>OPEN OR (CLOSE<=OPEN AND HIGH/LOW<1.049)),1) AND HIGH/CLOSE<1.013 AND CLOSE/OPEN>1.05;
VAR62:=VAR11+VAR16+VAR19+VAR32+VAR61>=2;
VAR63:=MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND MA(CLOSE,60)>MA(CLOSE,120) AND MA(CLOSE,5)>REF(MA(CLOSE,5),1);
VAR64:=CLOSE>REF(CLOSE,1)*1.1-0.01;
VAR65:=HHV(HIGH,20)=HHV(CLOSE,1) AND VOL>0 AND BARSCOUNT(CLOSE)*VAR2>=20;
VAR66:=VOL/REF(VOL,1)*VAR2>1.9;
VAR67:=VAR63 AND VAR64 AND VAR65 AND VAR66;
VAR74:=CLOSE/REF(CLOSE,1)>1.05 AND REF(CLOSE,1)/REF(CLOSE,2)<1.05 AND CLOSE/LLV(CLOSE,10)<1.4;
VAR75:=VOL/REF(VOL,1)>2 OR VOL=HHV(VOL,15);
VAR76:=CAPITAL<10000000;
VAR77:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*57.299999>40;
VAR78:=ATAN((MA(CLOSE,10)/REF(MA(CLOSE,10),1)-1)*100)*57.299999>30;
VAR79:=ATAN((MA(CLOSE,20)/REF(MA(CLOSE,20),1)-1)*100)*57.299999>20;
VAR80:=ATAN((MA(CLOSE,30)/REF(MA(CLOSE,30),1)-1)*100)*57.299999>10;
VAR81:=VAR77 AND VAR78 AND VAR79 AND VAR80;
VAR82:=kdj.K>REF(KDJ.K,1)*VAR2;
VAR83:=KDJ.D>REF(KDJ.D,1)*VAR2 AND KDJ.D<70;
VAR84:=KDJ.J>REF(KDJ.J,1)*VAR2;
VAR85:=VAR82 AND VAR83 AND VAR84;
VAR86:=VAR7 AND VAR74 AND VAR75 AND VAR76 AND VAR81 AND VAR85;
VAR87:=FILTER(VAR86,15)*VAR2;
VAR88:=VAR67 OR VAR87;
龍頭:((VAR88 AND VAR62)*VAR2 OR VAR35 OR VAR22);

買股指標公式展示
愛買股網股票展示推薦
手機版 | 電腦端
在線客服
本站數據全部免費提供,信息僅供參考,不構成投資建議,據此操作,風險自擔。粵ICP備2021140343號-1
精品国产免费第一区二区三